Running App Engine From Behind A Proxy

So, I am running Python 2.6.1 on my computer, and just installed google App Engine.

As soon as i click on the App Engine Launcher, it gives an error dialog box and asks me to check the GoogleAppEngineLauncher.exe file for more details.

I have appended the log file below:

   File "GoogleAppEngineLauncher.py", line 42, in <module>
   File "wx\_core.pyc", line 7913, in __init__
   File "wx\_core.pyc", line 7487, in _BootstrapApp
   File "launcher\app.pyc", line 58, in OnInit
   File "launcher\app.pyc", line 152, in _VersionCheck
   File "urllib.pyc", line 82, in urlopen
   File "urllib.pyc", line 190, in open
   File "urllib.pyc", line 338, in open_http
   File "urllib.pyc", line 351, in http_error
   File "urllib.pyc", line 702, in http_error_407
   File "urllib.pyc", line 714, in retry_proxy_http_basic_auth
   File "urllib.pyc", line 773, in get_user_passwd
   File "urllib.pyc", line 782, in prompt_user_passwd
   EOFError: EOF when reading a line

From the file, I get the feeling that It's about giving the right details about Proxy.

I have checked up http://code.google.com/p/google-appengine-wx-launcher/issues/detail?id=17
and http://code.google.com/p/googleappengine/issues/detail?id=544.

It seems that it is about making some edits to some particular .py file so that I can enter my proxy settings, and username/password.

I have also come across few suggestions telling me to set the proxy in environment variables at the command prompt - but that hasn't worked. Any suggestions, please?

asked 06 Jun '12, 13:52

Dharav%20Solanki's gravatar image

Dharav Solanki
4392420

accept rate: 42%


2 Answers:

What I did when I ran it under a proxy was, I added the environment variable "http_proxy" and set it to the proxy I was using (172.30.1.1) to my list of environment variables (go to My Computer -> Right Click -> Properties -> Advanced System Settings -> Advanced tab -> Environment variables.

I use Windows 7.

link

answered 06 Jun '12, 21:03

Ashwin%20Menon's gravatar image

Ashwin Menon
1.1k17

Thanks Ashwin. I have done that.

Before doing that:
App Engine Launches, but terminates as soon as it does with a dialog box.
Could run locally using command prompt
* Eclipse would run - but neither locally nor deploy

After doing the variables thing:
App Engine Runs and can run the web app locally.
Deploying is still a trouble.
* COmmand Prompt STILL can run locally but cannot deploy.

The problem, as seems to be on Google Code Issue 4849, seems to be with a urllib2 file : but I cannot figure out a way to use that patch!

link

answered 06 Jun '12, 21:40

Dharav%20Solanki's gravatar image

Dharav Solanki
4392420

Are you sure you are using the latest version of GAE?

(06 Jun '12, 21:52)

Ashwin Menon

Ashwin%20Menon's gravatar image

1.6.6 - thats the one I found on Google's website. I understand the whole problem with init.py should have been resolved on an update.

If you are behind a proxy that requires authentication - and you are able to deploy - it probably means that you have an updated init.py file. Could you send it over? You could host it on a dropbox public folder or something.

(06 Jun '12, 22:24)

Dharav Solanki

Dharav%20Solanki's gravatar image
1

If possible, you should upgrade to Python 2.7

(06 Jun '12, 22:55)

Stephan2

Stephan2's gravatar image

Do you mean init.py? All my init.py files seem to be empty except for comments. Oh, and I am not behind a proxy right now, unfortunately.

(06 Jun '12, 23:11)

Ashwin Menon

Ashwin%20Menon's gravatar image

I have updraded, Stephan. And I managed to make it work, finally!

(06 Jun '12, 23:42)

Dharav Solanki

Dharav%20Solanki's gravatar image
Your answer
Question text:

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags

×13,586
×2,215
×594
×402
×21

Asked: 06 Jun '12, 13:52

Seen: 1,024 times

Last updated: 06 Jun '12, 23:42