TUTORIAL: Deploying an App from Google App Engine

161

I've seen quite a few people posting on here with issues in deploying and even ran into a couple myself -- so hopefully this tutorial will help us all get launched and ready to go for Unit 2. :)


Note: This tutorial assumes that you've already registered an account for Google App Engines and have installed the related program -- we'll be showing how to navigate a few options here.

Deploying your application from your local machine to the Internet is as simple as hitting the blue 'Deploy' icon in Google App Engine's toolbar, but without knowing how to set things up first that could be quite a pain! For example, you could see an error like this...

Google App Engine displays an error -- "This application does not exist"

...when attempting to deploy. What could be causing this?

1) Create An Application

When attempting to first create an application, you're asked to specify two values -- an Application Identifier and an Application Title. The Application Identifier is tied to the URL you will access the application with online, and the application title could be whatever you want. I think a lot of people have made their title the same as their local directory name, like so...

A view of the "Create an App" page showing the Application Title as "hello-udacity".

A view of the Google App Engine Application overview.

...which has led to some problems, because the Application Identifier and the Application Title are being mistaken when we attempt to deploy. Don't worry though, fixing this is only a matter of changing a single line!

2) Checking app.yaml to confirm that Application is the same as Application Identifier

In your app's local directory, open the app.yaml file to edit. You can think of this as a sort of configuration file for the application. Inside, we're going to edit the first line called Application: and make sure that the information there matches our Application Identifier that we just registered online.

A view of the app.yaml file, with our new value on the first line.

If you noticed in the first error image, my app was initially named herpderp -- and has now been changed to hyperanthony to match the app that is online.

3) Deploy!

If all's well that ends well, you should be ready to go! Hit the blue deploy button and your app should launch successfully! You can check here to confirm that I'm not a dirty liar. :)


Other pitfalls: I can't input a valid password to deploy. It's asking for my google username and password, and I have two-step verification enabled.

In this situation, your password will not be your typical google password -- but rather a one time, application-specific password that you can generate from your Google account settings page. Under the Security header, click the Edit link to the right of "Authorizing applications & sites." Scroll to the bottom of the page, and there should be a text field with a button next to it that says "Generate."

In the text field, type something that will let you remember what this password is for -- Google App Engine or Udacity, for example -- and then press generate. This password will be the one you need to use to deploy!


Other pitfalls: How can I edit app.yaml?

A simple word editor should allow you to edit app.yaml -- something like notepad or vi or vim on Linux/Mac from the terminal. Just type vim app.yaml and the text editor will open. Here's a vim cheatsheet for help navigating.


Other pitfalls: I'm using Mac and have Python pre-installed, and I get the error "Python 2.5 is too old to emulate the Python 2.7 runtime. Please use Python 2.6 or Python 2.7."

Mac OS X 10.7 (Lion) supports Python 2.7, but anything before that will come installed with an earlier version of Python (likely 2.5) and so you'll need to update. You can download a more recent version here.

asked 22 Apr '12, 14:57

Anthony%20Neace's gravatar image

Anthony Neace
4.9k2614

accept rate: 200%

edited 22 Apr '12, 20:00

1

Great tutorial Anthony! Just as an appendix, lemme add a link to a how-to I did to install google app on Mac OS: http://forums.udacity.com/cs253-april2012/questions/4389/how-ive-made-the-google-app-work-for-me-mac-os-x

(22 Apr '12, 22:40)

ricardo miki...

ricardo%20mikio%20morita's gravatar image

@ricardo mikio morita Sure thing, thanks for sharing! You mentioned in your link that you had some warning messages pop up and it looks like nobody ever answered you on that -- you might want to reply to/edit your post with some more details on those warning messages so maybe somebody could figure them out. :)

(22 Apr '12, 23:02)

Anthony Neace

Anthony%20Neace's gravatar image

That two-step verification thing really is a PITA, thanks for the advice on that bit! I had nearly given up :)

(23 Apr '12, 19:07)

Andy Hayden

Andy%20Hayden's gravatar image

Saved me a lot of unproductive effort! Thank you so much!!

(24 Apr '12, 01:52)

Rishav Agarwal

Rishav%20Agarwal's gravatar image

thank you! I was going nowhere before I saw this

(24 Apr '12, 12:12)

gmirt

gmirt's gravatar image

Thank you so much. this helped me finally get my app deployed. I can see it now at http://fanudacityapp1.appspot.com. even if I have never figure out to see it on my localhost. (I can run 127.0.0.1:8082 but not localhost 8082)

(24 Apr '12, 16:56)

Fan

Fan's gravatar image

@Fan Were you similarly using the colon to separate localhost and 8082?

(25 Apr '12, 02:46)

Anthony Neace

Anthony%20Neace's gravatar image

You don't need python 2.7 to run GAE. 2.7 was added about 6mo ago and had major performance problems, from what i read i don't feel comfortable switching yet. The reason you are getting the error shown is because your app.yaml specifies you want python27, which you apparently did not have.

(01 Jun '12, 17:41)

EnTerr

EnTerr's gravatar image

I am getting errors from the following lines and below:
Starting update of app: benholdingcs253, version: 1
10:22 AM Getting current resource limits.
2012-11-13 10:22:42,562 ERROR appcfg.py:2202 An error occurred processing file '': <urlopen error="" tunnel="" connection="" failed:="" 407="" proxy="" authorization="" required="">. Aborting.
~
ending with:
2012-11-13 10:22:42 (Process exited with code 1)

I have tried deploying both from home and from work computers but seem to going no where. Can you help? Am I missing something really obvious?

(13 Nov '12, 05:32)

Ben Holding

Ben%20Holding's gravatar image

Thanks so much!

(03 Jun '13, 17:55)

Pooja M

Pooja%20M's gravatar image

Thank you so much!! Your solution helped me to solve this problem I had spent along time on......

(17 Jul '13, 12:20)

Luxuan

Luxuan's gravatar image

some light at the beginning of tunnel, great job @anthony!

(19 Nov '13, 05:20)

SUDHIR KUMAR...

SUDHIR%20KUMAR%20SINGH's gravatar image
showing 10 of 12 show 2 more comments

33 Answers:

1234next »

God Bless you God Bless you God Bless you God Bless you God Bless you God Bless you God Bless you :-)

link

answered 10 Jul, 04:50

Hamza-31's gravatar image

Hamza-31
262

When I clicked Deploy I get error message:

Fatal Error
No deploy command (installation problem?)

Why is that?

link

answered 27 Jun, 16:19

Sebastian-168's gravatar image

Sebastian-168
11

Thanks man! I was missing the Deplot part! Nice tutorial!

link

answered 20 Jan, 22:24

Adolfo-27's gravatar image

Adolfo-27
715

https://www.youtube.com/my_videos_upload
have a look at this video .............

link

answered 16 Jun '13, 08:22

ankur-3's gravatar image

ankur-3
51411

my app.yaml has same application name still error is coming..
why??

link

answered 04 Nov '13, 12:47

shavika's gravatar image

shavika
261

@ shavika.. you can watch the youtube link below and if the error exists, mail me at bikesorcars@gmail.com

(05 Nov '13, 01:24)

ankur-3

ankur-3's gravatar image

still same error is occuring
i dont know why?
my app id same in app.yaml
please someone tell me whats wrong?

(12 Nov '13, 13:15)

shavika

shavika's gravatar image

-1

ChuckDone iPhone App By Masiar Ighani

Open iTunes to buy and download apps.

https://itunes.apple.com/us/app/chuckdone/id642199600?mt=8&ign-mpt=uo%3D2

Description

Who is ChuckDone ? The kind of guy who slams revolving doors; a man who lights fires with ice cubes – that’s who. ChuckDone is the type who simply knows how to get things done. He’ll even help you annihilate your task lists too.

A rough-and-tumble outlaw, ChuckDone creates to-dos, destroys checkboxes when tasks are completed, and makes running errands and tackling chores an entertaining blood sport – while improving your productivity in the end.

Dispatched to help you decimate duties as your personal assistant, ChuckDone is just as much a legend as you ever thought him to be.

** Easily add tasks and build lists with ChuckDone, and sit back and enjoy the action as those tasks are removed.

** His shotgun blows checkboxes to smithereens; his katana blade slices through with a flick of a wrist. The rest of his arsenal comprised of grenades, dynamite, rocket launchers, flamethrowers, ferocious dogs, heavy pianos, and dive-bombing planes are waiting to be unleashed through the app’s 20 different custom animations.

So, don’t just get things done, get ChuckDone.

• Create unlimited lists – The word “limited” isn’t in ChuckDone’s vocabulary. Create a list for you, your significant other, your kids, dog, cat, whoever. Make one list for the upcoming weekend or one for just another day of the week. Create a list of resolutions for the New Year or for any impending event.

• Stay on task; keep motivated – ChuckDone can create task lists in his sleep; as anyone can. Staying motivated is the key. You create the list and ChuckDone does the motivating, pushing you to keep moving forward via fun, entertaining animations.

• Celebrate your victories – ChuckDone doesn’t assist in simply setting goals…he helps you overcome obstacles en route to achieving them. He then joins in the celebration with 20 custom animations, obliterating checkboxes with each item ticked off your list. His arsenal is robust; his methods nothing but intense.

$.99 introductory price!!!
Buy now, experience ChuckDone as your personal task-crushing assistant, and offer feature suggestions for subsequent releases. Have a say in Chuck’s carnage by visiting http://voting.chuckdone.com and casting a vote for the method of madness you’d like to see unfold.

link

answered 05 Jun '13, 06:42

Masiar-1's gravatar image

Masiar-1
6

Thanks very much, this was very helpful!

link

answered 02 May '13, 21:03

Jim-74's gravatar image

Jim-74
111

Thank you!
I didn't realize the id had to be the same as the first line in app.yaml.
Then I figured out I was supposed to go to that website to test it.
Thank you.

link

answered 17 Apr '13, 21:49

Jill-9's gravatar image

Jill-9
412

Guys,

My name is Hernan. I am an NYU graduate student conducting my research thesis on Self-Motivated Learners, specifically on “How to Increase MOOC Engagement.”

If you’ve enrolled in Udacity’s “Web Development” course -- regardless of whether you’ve completed it or not -- would you be so kind as to answer this 2-minute questionnaire?

http://surveymonkey.com/s/Udacity_Web_Development

Many thanks!
Hernan

link

answered 02 Apr '13, 08:47

Hernan-1's gravatar image

Hernan-1
281

Thank you Anthony! you're the best. very useful

link

answered 19 Mar '13, 09:44

Paula-17's gravatar image

Paula-17
11

Your answer
Question text:

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags

×13,931
×9,099
×689
×601
×75
×59
×34
×22

Asked: 22 Apr '12, 14:57

Seen: 15,513 times

Last updated: 10 Jul, 04:50